FAQ do Firefox

Este é o FAQ do Firefox, que contém as perguntas mais comuns sobre o Firefox.

Conteúdo

Perguntas Comuns

O que é Firefox?

Firefox é navegador livre, portanto, de código aberto, disponível para Windows, Linux e MacOS X, baseado no código do Mozilla. É pequeno, rápido e fácil de usar e possui muitas vantagens sobre o Internet Explorer, como bloqueio de janelas pop-up. Leia mais sobre o navegador página do Firefox (em inglês).

O que é Mozilla?

Mozilla é um navegador web e um conjunto de ferramentas de código aberto, desenvolvido para conformidade com padrões, performance e portabilidade. A Mozilla Foundation coordena o desenvolvimento e teste do Firefox disponibilizando fóruns de discussão, ferramentas de engenharia de software, versões dos produtos e mapeamento de bugs. Para mais informações sobre mozilla.org, leia Visão Geral sobre o Mozilla (em inglês).

Qual é a diferença entre Firefox e Mozilla?

O Mozilla (suíte, também conhecido como Seamonkey) é uma conjunto completo de programas para web, como navegador, cliente de e-mail/newsgroup, cliente de bate-papo e muito mais. O Firefox é apenas um navegador que é uma escolha melhor se você já tem um cliente de e-mail, por exemplo. Além disso, como o Firefox é menor do que a suíte Mozilla completa é mais rápido e mais fácil de usar.

Note, no entanto, que o Firefox não é apenas o navegador Mozilla autônomo. No Firefox a interface de usuário difere da interface do Mozilla em muitas coisas. Por exemplo, o Firefox tem barras de ferramentas personalizáveis.

Por que usar o Firefox em vez de outros browsers?

Ben Goodger escreveu um excelente artigo a respeito das razões pelas quais você deveria usar o Firefox em vez de outros browsers disponíveis no mercado.

Firefox é mais seguro que o Internet Explorer?

Sim, o Firefox e todos os outros produtos baseados no Mozilla são mais seguros. Por que? Aqui está uma lista dos motivos mais importantes:

  • Ele não é integrado com o Windows, o que ajuda a evitar que vírus e piratas causem danos caso o Firefox caso algo comprometa o Firefox.
  • Não há suporte a VBScript e ActiveX, duas tecnologias responsáveis por muitas falhas de segurança do IE.
  • Spywares e adwares não podem ser automaticamente instalados apenas visitando um site.
  • Firefox não usa a Máquina virtual (Virtual Machine) Java da Microsoft que tem mais falhas de segurança do que outras Máquinas virtuais.
  • Você tem controle total sobre os cookies.
O Firefox é livre?

Sim! O Firefox é um software de código aberto, o que significa que qualquer tem o direito de baixá-lo e usá-lo livremente, acessar e modificar o código fonte sob os termos da licensa.

Posso ter tanto o Firefox quanto o Mozilla instalados em um mesmo computador?

Sim. O Firefox e a suíte Mozilla usam perfis diferentes que não interferem entre si. No Linux, porém, pode haver problemas ao iniciar o Firefox caso o Mozilla já esteja rodando.

Onde posso baixar o Firefox?

Para baixar o Firefox, vá até a Página de Produtos deste site.

Como instalar o Firefox?

Veja as notas da versão (release notes) para mais detalhes.

Como desinstalar o Firefox?

Se você instalou o Firefox usando o instalador para Windows, simplesmente use a opção Adicionar ou Remover Programas no Painel de Controle do Windows.

Se você instalou o Firefox a partir dos arquivos compactados apenas remova a pasta em que você descompactou.Opcionalmente, remova a pasta de perfil,, que contém todos os seus bookmarks e configurações.

Qual é a diferença entre "releases" e "nightlies"?

"Releases" são geralmente versões mais estáveis do Firefox que provavelmente serão baixadas pelos usuários iniciantes. "Nightly builds" são lançadas todas as noites e contêm as últimas alterações, incluindo novos recursos e bugs. Não espere que tudo funcione nas "nightly builds".

O Firefox está disponível em meu idioma?

Possivelmente. Visto que o Firefox é um projeto de código aberto, voluntários estão constantemente traduzindo o Firefox em seus idiomas. Você pode verificar se o Firefox está disponível em sua língua na página de notas da versão (release notes).

Onde está o cliente de e-mail?

O Firefox é apenas um navegador, não é uma solução web completa. No entanto, há um ótimo cliente de e-mail e newsgroup chamado Mozilla Thunderbird. quem também tem um site de ajuda semelhante a este: Ajuda do Thunderbird.

Sou um usuário Linux; o Mozilla Firefox suporta XFT?

Sim, compilações oficiais com suporte XFT estão disponíveis no mozilla.org. Vá até a página de notas da versão (release notes)para mais informações.

Onde estão meus bookmarks, senhas e outras informações pessoais?

O Firefox armazena suas informações pessoais como bookmarks, cache e dados de formulários em umapasta de perfil. Consulte a próxima pergunta para mais informações a respeito do gerenciamento de perfis.

Como iniciar o Gerenciador de Perfis?

O Gerenciador de Perfis é usado para gerenciar mútiplos perfis. Para iniciar o Gerenciador de Perfis no Windows siga estes passos:

  1. Feche o Firefox completamente (clique no menu Arquivo > Sair).
  2. Clique em Iniciar > Programas > Gerenciador de perfis.

Em outros sistemas operacionais inicie o Firefox com o parâmetro -profilemanager, por exemplo, ./firefox -profilemanager

Ao iniciar você poderá adicionar, remover ou renomear perfis. Note que o Gerenciador de perfis pode ser removido em versões futuras do Firefox, o que pode exigir que você use parâmetros da linha de comando em vez da interface gráfico.

O que é o Talkback?

Se o Firefox finaliza de maneira anormal, é aberto um programa chamado Talkback, pedindo-o para enviar informações sobre o problema. Asa Dotzler do mozilla.org escreveu uma boa explicação sobre o que é o Talkback:

Talkback é um programa cliente-servidor (além de infrastrutura e pessoal de desenvolvimento/administração) fornecido ao mozilla.org pela Netscape. Mozilla.org, muitos anos depois, aceitou abrir uma exceção e incluir este produto com nossas distribuições binárias "nightly" e "milestone" porque agrega enorme valor à depuração e isolamento de problemas de estabilidade. Talkback é usado para identificar e depurar milhares de grandes falhas no Mozilla ao longo dos anos e nós estamos muito felizes por podermos incluí-lo nas compilações de teste do Mozilla Firefox.

Como funciona: Um binário do Talkback é incluído no binário do navegador Mozilla Firefox. Quando o navegador finaliza de maneira anormal, o programa Talkback é chamado e oferece ao usuário a opção de colaborar. Se o usuário diz não, então nada acontece. Se o usuário aceita ajudar a equipe do Mozilla com seus esforços enviando dados sobre a falha, então fornece ao usuário campos opcionais para incluir seu e-mail, a URL com a qual ocorreu o problema e um comentário. Esses dados fornecidos pelo usuário com o stacktrace da falha são enviados ao servidor Talkback na Netscape que é acessado por muitos dos desenvolvedores do Mozilla. Além disso, todos os dados da falha podem apontar muito rapidamente para problemas específicos que são encontrados por grandes grupos de usuários. Uma pequena equipe de engenheiros agrupa estes relatórios e transforma-os em bugs do bugzilla com boas informações de depuração que permitem corrigir rapidamente os problemas de estabilidade de alta prioridade. Para ver alguns desses bugs, procure no buzilla usando as palavras-chave topcrash e topcrash+

O que mais:Talkback não é um spyware, adware ou qualquer coisa dessa natureza. Os usuários são claramente informados e solicitados a enviar o relatório. Dados de usuário não relacionados com a falha do Mozilla são inúteis para nós. Nós apenas preocupamo-nos em tornar o Mozilla mais estável. Se você não quer ajudar a tornar mais estável o Mozilla e o Firefox enviando seu relatório de falha então não faça isso. Nenhum dado será enviado sem sua explícita autorização. Eu incentivo a enviar esses relatórios a qualquer um que queira ver este navegador melhorar. Estes são muito, muito úteis. Mas, como eu digo, se você não quer, então não faça. Apenas lembre-se de que nós não podemos corrigir bugs que nós não identificamos. Se você está satisfeito em ver a mesma falha repetidamentente, não se preocupe com o envio desses relatórios.

Plugins

Como instalar o Flash?

Para Windows, este plugin popular pode ser encontrado aqui. Para usuários Linux, esse plugin deve funcionar. Baixe o arquivo, feche o Firefox completamente ( Arquivo > Sair) e proceda a instalação. Na janela que aparecer, clique no botão Other browser.... Então você tem que especificar o caminho para a pasta de plugin do Firefox. Você deveria saber em qual pasta instalou o Firefox. Nessa pasta, á uma subpasta chamada "plugins". Selecione essa pasta e clique Select, então clique em Install.

Nota de tradução: O instalador em Linux não tem uma interface gráfica. Após fechar completamente o Firefox, abra um terminal e mude para o diretório em que baixou o arquivo install_flash_player_6_linux.tar.gz.

  • tar -xzvf install_flash_player_6_linux.tar.gz
  • cd install_flash_player_6_linux
  • ./flashplayer-installer

Após confirmar com ENTER algumas questões, será solicitado o diretório em que foi instalado o Firefox. Apenas informe-o e dê ENTER. Após a instalação, o instalador perguntará se deseja instalá-lo para outros navegadores. Faça a escolha apropriada.

Como instalar o Java?

Windows

No Windows o Firefox pode ser usado com o Java Runtime Environment (JRE) da Sun. Ele não pode ser usado com o Microsoft Java VM, pois este só pode ser usado com o Internet Explorer. Versões do JRE da Sun mais antigas que 1.3.0_01 não funcionarão.

É possível instalar o JRE 1.4.2_01 a partir do Firefox, usando a tecnologia XPInstall.

De longe, a maneira mais fácil de fazer o Java funcionar é instalar o Firefox com o Instalador Não Oficial e então instalar o Java usando XPInstall.

Se você já instalou o Firefox apartir de um arquivo ZIP, você pode adicionar manualmente ao registro as informações requeridas pelo JRE 1.4.2 e posteriores. Para isso, salve este arquivo de registro na sua área de trabalho e clique duas vezes para importar. Se você for solicitado a adicionar a informação ao registro do Windows, clique em "Sim"Depois disso você pode instalar o JRE 1.4.2 se necessário e então reiniciar o Firefox e usar o Java.

Se nenhuma das soluções funcionarem, você pode usar o JRE 1.4.1_05 até que o problema que você tem seja resolvido. JRE 1.4.1_05 não requer informações no registro do Windows que JRE 1.4.2 precisa.

Linux

No Linux o Firefox requer JRE 1.4.2 ou posterior.

Firefox é compilado com gcc 3.2.3, então uma versão compatível do plugin Java tem que ser usada. O JRE 1.4.2 contém um plugin compatível.

Se você instalou o RPM do JRE 1.4.2_01 RPM, este plugin é /usr/java/j2re1.4.2_01/plugin/i386/ns610-gcc32/libjavaplugin_oji.soe para instalá-lo para o Firefox, faça o seguinte:

  • Abra um terminal
  • Vá ao seu diretório de plugins do Firefox
  • Entre com o seguinte comando: ln -s /usr/java/j2re1.4.2_01/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

Se você está utilizando uma distribuição Linux antiga, você pode precisar instalar as bibliotecas de suporte ao gcc3 pois o plugin Java versão gcc 3.2 requer libgcc_s.so.1 para funcionar. Você pode procurar pacotes usando o Google.

Se está usando uma versão não oficial do Firefox, você deveria verificar qual compilador foi usado digitando about:buildconfig na barra de endereços e pressionando enter. Você verá uma linha como "gcc version 3.3 20030226 (prerelease) (SuSE Linux)", que mostrará o compilador que foi usado. Se foi usado o gcc2.9x, você precisará usar o plugin ns610 e não o ns610-gcc32.

MacOS X

O JRE 1.4.1 não funcionará com o Firefox (Bug 197813Bug 197813). Os applets Java serão exibidos usando o JRE 1.3.1.

Notas

Você não deveria usar Java com um useragent falso, pois isso pode causar finalizações anormais (Bug 83376 - JRE). Você deveria também remover qualquer arquivos de plugin Java do seu computador ao instalar uma nova versão do JRE (se você já tem alguma).

Como instalar outros plugins (Shockwave, QuickTime, etc.)?

O PluginDoc lista os plugins comuns, como RealPlayer, QuickTime, etc, e indica como instalá-los no Firefox.

Por que os arquivos pdf gastam tanto tempo para carregar no Windows?

O Adobe Reader 6.0 para Windows carrega uma porção de plugins ao iniciar. O "The Inquirer" tem um ótimo artigo que explica como você pode disable those unneeded pluginsdesativar os plugins desnecessários e fazer o Adobe Reader iniciar mais rapidamente. Basicamente é preciso fazer o seguinte:

  1. Instale o Adobe Reader 6.0 e anote o nome da pasta.
  2. Navegue na pasta no Explorer, localize a subpasta plug_ins e renomeie esta pasta para plug_ins_desativados.
  3. Crie uma nova pasta plug_ins.
  4. Mova os arquivos EWH32.api, printme.api e search.api da pasta plug_ins_desativados para plug_ins.

Extensões

O que são extensões?

Extensões são melhorias na experiência de navegação com o Firefox. Elas podem ser entendidas como pequenos programas (ou add-ons) que acrescentam novas funcionalidades ao Firefox.

A grande importâcia das extensões é que elas permitem ao Firefox ser pequeno e ágil. Qualquer um que precisar de mais recursos pode baixar as extensões apropriadas.

Onde posso encontrar extensões?

Veja mais sobre várias extensões na página de Extensões.

Como desinstalar Extensões?

Clique em Ferramentas > Extensões. Selecione a extensão que deseja remover e clique no botão Remover.

Eu quero mais recursos de navegação por abas!

Você provavelmente encontrará recursos de que sente falta instalando a extensão Tabbrowser. Ela adiciona recursos como botões para fechar para cada abas, escolha da ordem de fechamento de abas, auto recarregar, recuperação de falhas e muito mais.

O Firefox suporta Gestos de Mouse?

Sim, através de uma extensão. Gestos de Mouse são recursos originários do navegador Opera que permitem navegar usando simplesmente movimentos do mouse. Por exemplo, você pode voltar uma página pressionando um botão e arrastando o mouse para a esquerda. Dê uma olhada na página de instruções para informações mais detalhadas sobre como usar este recurso ou apenas baixe a extensão e experimente-a.

Migração

Posso usar os bookmarks do Netscape 6/7 ou do Mozilla no Firefox?

Sim, você pode! Aprenda como fazer isso na seção Dicas & Truques.

Posso compartilhar meus bookmarks num dual-boot?

Sim, você também pode. Aprenda como fazer isso na seção Dicas & Truques.

E os bookmarks do Opera?

Se você usa Windows pode converter os bookmarks com a ajuda do BookmarkPriest. Se você usa Linux há um programa chamado bk_edit que permite editar e converter bookmarks do Opera 6, Netscape 3/4, Mozilla (incluindo, é claro, o Firefox) e Galeon no Linux.

Uso o Galeon ou o Konqueror, posso importar meus bookmarks para o Firefox?

Tanto o Galeon quanto o Konqueror usam o formato XBEL para armazenar bookmarks. O Firefox não pode importar diretamente estes arquivos pois armazena bookmarks em HTML, enquanto o XBEL é XML. Porém, tanto o Galeon quanto o Konqueror oferecem o recurso de exportar seus your bookmarks para o formato Mozilla/Netscape (que é o formato usado pelo Firefox).

Após exportar seus bookmarks abra o Gerenciador de Bookmarks do Firefox e importe (Arquivo > Importar) o arquivo recém exportado.

Como copiar as senhas do Mozilla para o Firefox?

Se você usa senhas criptografadas no Mozilla, vá até a pasta de perfil do Mozilla, copie os arquivos xxxxxxxx.s e key3.db para a pasta de perfil do Firefox. Renomeie o arquivo xxxxxxxx.s para signons.txt.

Operação

Como personalizar a Barra de Ferramentas?

Você pode personalizar a barra de ferramentas escolhendo que botões você quer exibir, adicionando novas barras de ferramentas ou redimensionando os botões. Para isso, vá até Exibir > Barra de ferramentas > Personalizar.... Uma nova janela contendo os ítens disponíveis nas barras de ferramentas será aberta. Apenas arraste e solte-os sobre a barra de ferramentas em que você quer adicioná-lo. Para remover alguns itens da barra de ferramentas, arraste-os sobre a janela Personalizar...

Você pode também colocar os itens da barra de ferramentas na barra de menus! Isto lhe permitirá colocar tudo em uma barra, economizando grande parte do espaço de trabalho da janela.

Firefox ainda não permite mover as barras de ferramentas. Isto está planejado para versões futuras.

Posso personalizar o ícone do Mozilla Firefox na Barra de Tarefas?

Sim, você pode. Siga as instruições da dica Mudar o ícone da janela. Houve pedidos para arte-final do ícone para o projeto Firefox e os desenvolvedores já decidiram a respeito de um. Aguarde que o Firefox terá seu próprio ícone bonito para que você se maravilhe logo.

Posso usar diferentes temas no Mozilla Firefox?

Sim! Visite a Seção de Temas para obter a lista de temas disponíveis.

Quais são os atalhos de teclado para um [recurso qualquer]?

Veja a tabela Atalhos de Teclado neste site para obter uma lista completa dos mais comuns.

Onde estão as dicas das imagens?

Muitos sites usam a propriedade HTML alt para exibir dicas de imagens. Isto está errado. A propriedade correta a usar para dicas é title. A propriedade alt tem uma utilidade muito importante que é fornecer texto substituto para imagens em navegadores que não podem exibir imagens ou não exibem (por escolha do usuário) e se navegadores gráficos exibem-os como dicas as pessoas não deveriam usá-las dessa forma e sim da maneira correta. Para mais informações sobre isto leia o Bug Mozilla 25537. Em outras palavras, isto é para que os desenvolvedores web usem a propriedade correta para dicas. Se você está em dúvida, leia aqui para mais informações.

Porém, há uma extensão que permitirá exibir a propriedade alt como dica. Você pode instalá-la a partir deupdate.mozilla.org.

Os Links para E-mail parecem não funcionar no Firefox?

Se você está usando o Mozilla como seu cliente de e-mail você provavelmente percebeu que o Firefox ou não faz nada ou inicia o Outlook Express quando você clica em um link mailto. Isto acontece porque o Mozilla Mail não se registra corretamente como o programa padrão responsável pelo protocolo mailto no Windows. Você terá que corrigir isto manualmente.

Nos Windows XP/2000, selecione Opções de Pasta no Painel de Controle e então clique na aba Tipos de Arquivos. Procure o tipo de arquivo chamado (Nenhum) URL:Protocolo MailTo e clique em Avançado. Selecione a ação Abrir e clique em Editar. Desmarque a opção Usar DDE e especifique o caminho completo para o mozilla.exe no campo Programa usado para executar a ação. Delimite o caminho com aspas duplas e inclua -compose %1. O resultado deveria parecer com algo semelhante a isto:

"C:\Arquivos de Programas\mozilla.org\Mozilla\mozilla.exe" -compose %1

Outra solução e seria parar de usar a suí de aplicativos Mozilla e em vez disso usar o cliente de email independente Mozilla Thunderbird.

Quando eu clico em um link a partir de outro programa o Firefox abre uma nova janela. Posso usar abas nesse caso?

Sim. Usando a Extensão Tabbrowser isto é possível. Depois de instalar a extensão, procure nas Preferêcias por Navegação Avançada por Abas > Advanced > Tabbed Browsing > Advanced > Modo de Única Janela.

Leia mais sobre isso na dica Abrir links externos em novas janelas ou abas.
Uso o Windows 95/98/Me. Por que o logotipo do Windows aparece no lugar do ícone do navegador?

No Windows 95/98/Me as janelas do Firefox mostram o ícone padrão em vez do ícone vermelho do Firefox. Isto acontece devido a um bug no Firefox. Para contornar isto você pode usar qualquer ícone que quiser, conforme a dica alterar ícone da janela.

Eu quero criar meu próprio tema para o Firefox (ou Mozilla). Mostre-me como, por favor!

Criar um tema exige conhecimento de Cascading Style Sheets (CSS) e não é para aqueles de coração fraco. Se você tem tempo para aprender ou pensa que conhece bastante de web design, um bom lugar para começar Criando um skin para Mozilla.

Além disso, o Mozilla DOM Inspector é muito útil na tentativa de compreender que propriedades definir. Este não está disponível no Firefox por padrão mas pode ser incluído facilmente se você mesmo compilar.

OK. Em vez de um tema totalmente novo, posso modificar algumas caracteríticas da interface do usuário?

Bons amigos do Mozilla.org forneceram neste link algumas informações que podem ser aplicadas em seu arquivo userChrome.css. Há também algumas dicas na página Dicas e Truques.

Como posso acessar ou mudar a senha mestra?

Clique em Ferramentas > Opções... e selecione a seção Privacidade. Clique em Senhas Senhas salvas e então no botão Definir senha mestra....

© 2002-2004 David Tenser.


firefox firefox community website