Dicas & Truques

Esta página contem várias dicas e truques para o Firefox. A maioria das dicas envolve edição de arquivos texto em seu disco rígido e não são recomendadas se você não estiver familiarizado com manipulação básica de arquivos e pastas. As dicas são divididas em quatro categorias e ordenadas por importância/popularidade.

Conteúdo

Aparência do Navegador

Usar menus no estilo do Windows XP

Se você roda Windows XP e quer que seus menus no Firefox sejam iguais ao estilo padrão (Luna), adicione o seguinte código ao seu arquivo userChrome.css:

/* Menus no estilo XP */
menupopup, popup {
   border: 1px solid ThreeDShadow !important;
   -moz-border-left-colors: ThreeDShadow !important;
   -moz-border-top-colors: ThreeDShadow !important;
   -moz-border-right-colors: ThreeDShadow !important;
   -moz-border-bottom-colors: ThreeDShadow !important;
   padding: 1px !important;
   background-color: Menu !important;
}
menubar > menu {
   border: 1px solid transparent !important;
   padding: 2px 5px 2px 7px !important;
   margin: 0 !important;
}
menubar > menu[_moz-menuactive="true"] {
   background-color : Highlight !important;
   color: HighlightText !important;
}
Usar menus no estilo Clássico do Windows (9x/Me/2000)
Infelizmente a aparência dos menus do Firefox na versão atual é, de alguma forma, um compromisso entre os menus não 3D do Windows XP e a aparêcia de versões anteriores do Windows. Se quiser os menus com a aparência clássica do Windows, adicione o seguinte código ao seu arquivo userChrome.css :

/* menus no estilo Clássico do Windows (9x/Me/2000) */
menupopup, popup {
   border: 2px solid !important;
   -moz-border-top-colors: ThreeDLightShadow ThreeDHighlight;
   -moz-border-right-colors: ThreeDDarkShadow ThreeDShadow;
   -moz-border-bottom-colors: ThreeDDarkShadow ThreeDShadow;
   -moz-border-left-colors: ThreeDLightShadow ThreeDHighlight;
   padding: 1px !important;
}
menubar > menu[disabled="true"] {
   border: 1px solid transparent !important;
}
menubar > menu[_moz-menuactive="true"] {
   border-top: 1px solid ThreeDHighlight !important;
   border-right: 1px solid ThreeDShadow !important;
   border-bottom: 1px solid ThreeDShadow !important;
   border-left: 1px solid ThreeDHighlight !important;
   background-color: transparent !important;
   color: MenuText !important;
}
menubar > menu[_moz-menuactive="true"][open="true"]  {
   border-top: 1px solid ThreeDShadow !important;
   border-right: 1px solid ThreeDHighlight !important;
   border-bottom: 1px solid ThreeDHighlight !important;
   border-left: 1px solid ThreeDShadow !important;
}
Usar sua própria imagem de fundo nas barras de ferramentas

Alé da alteração de temas você pode personalizar o Mozilla Firefox ainda mais, usando sua própria imagem como fundo das barras de ferramentas. Adicione o seguinte código ao seu arquivo userChrome.css:

/* Usar imagem de fundo nas barra de ferramentas:
   (Substitua background.gif por seu arquivo de imagem) */

 menubar, toolbox, toolbar, .tabbrowser-tabs {
   background-image: url("background.gif") !important;
   background-color: none !important;
 }

O mais fácil é colocar o arquivo de imagem é na mesma pasta do arquivo userChrome.css. A imagem pode ser de qualquer formato suportado pelo Firefox.

Tornar a aba ativa mais fácil de distinguir

Para tornar a aba ativa mais fácil de distinguir que as outras abas abertas, você pode mudar as cores das abas. Adicione o seguinte código ao seu arquivo userChrome.css:

/* Muda a cor da aba ativa */
tab{
   -moz-appearance: none !important;
}
tab[selected="true"] {
   background-color: rgb(222,218,210) !important;
   color: black !important;
}

/* Change color of normal tabs */
tab:not([selected="true"]) {
   background-color: rgb(200,196,188) !important;
   color: gray !important;
}
Não usar texto em negrito na aba ativa

Se você não quer que o título da aba ativa em negrito, adicione o seguinte código ao seu arquivo userChrome.css:

/* Faz com que a aba ativa não esteja em negrito */
tab[selected="true"] {
   font-weight: normal !important;
}
Remover o botão `Fechar aba' da barra de abas

You can remove the close button from the tab bar by adding the following code to your userChrome.css file:

/* Remove the close button on the tab bar */
.tabs-closebutton {
   display: none !important;
}

Você pode fechar as abas clicando com o botão direito do mouse sobre a aba e selecionando Fechar aba ou pressione  Ctrl+W

Remover ítens do menu principal

Algumas pessoas preferem colocar todos os ítens da barra de ferramentas na mesma linha que o menu. Para ganhar espaço horizontal, você pode remover itens do menu que não usa. Adicione o seguinte código ao seu arquivo userChrome.css:

/* Remove os menus Ir e Ajuda
   (Estes são apenas exemplos. Tente alterar "Ir" or "Ajuda" por "Editar" ou "Favoritos") */
menu[label="Ir"], menu[label="Ajuda"] {
   display: none !important;
}
Remover espaçamento extra da barra de Navegação

This tip will make the toolbars use less space around the buttons, allowing Firefox to use more space for the actual webpages. This also affects additional toolbars such as the Googlebar. Add the following code to your userChrome.css file:

/* Remover espaçamento extra da barra de Navegação */
.toolbarbutton-1, .toolbarbutton-menubutton-button {
   padding: 2px 3px !important;
}
.toolbarbutton-1[checked="true"], .toolbarbutton-1[open="true"],
.toolbarbutton-menubutton-button[checked="true"],
.toolbarbutton-menubutton-button[open="true"] {
   padding: 4px 1px 1px 4px !important;
}
Alterar o ícone da janela

Você pode alterar o ícone padrão da janela do Firefox para qualquer um que quiser, seguindo estes passos:

  1. Vá para a pasta que o Firefox está instalado (ex. C:\Arquivos de programas\Firefox\) e então vá para a sub-pasta chrome.
  2. Dentro da pasta chrome, crie uma nova sub-pasta chamada icons, Vá para esta pasta e crie uma outra sub-pasta chamada default. O caminho completo desta pasta pode ser C:\Arquivos de programas\Firefox\chrome\icons\default\.
  3. Escolha o ícone que você quer usar (no Windows use um arquivo .ico, no Linux use um arquivo .xpm) e então copie-o para esta subpasta e renomeie-o para main-window.[ext], por exemplo, main-window.ico em Windows e main-window.xpm no Linux.

Além da janela principal, você pode mudar o ícone do Gerenciador de Favoritos e Console do JavaScript. Os nome dos ícones são bookmark-window.[ext] e jsconsoleWindow.[ext], respectivamente.

Feito isso, reinicie o Firefox e você poderá ver o ícone escolhido no título da janela do navegador. Um belo ícone Qute para Windows, feito pelo autor do tema padrão do Mozilla Firefox pode ser encontrado aqui.

Exibir Painel à direita

Para exibr o Painel no lado direito da janela em vez de mostrá-lo no lado esquerdo, adicione o seguinte código ao seu arquivo userChrome.css:

/* Posiciona a sidebar no lado direito da janela */
/* Place the sidebar on the right edge of the window  */
window > hbox {
   direction:rtl;
}
window > hbox > * {
   direction:ltr;
} 
Alterar largura da barra de pesquisa

Por padrão,  a barra de pesquisa na barra de ferramentas é relativamente pequena. Para especificar sua largura em pontos, adicione o seguinte código ao seu arquivo userChrome.css:

/* Aumenta a largura da barra de pesquisa (neste caso, largura
de 400 pontos) */
 #search-container, #searchbar {
   -moz-box-flex: 400 !important;
}

Comportamento do Navegador

Abrir links externos em novas janelas ou abas

Se outro programa quer mostrar uma página web no navegador padrão, o Firefox reutilizará por padrão uma janela existente, o que significa que esta página abrirá sobre uma outra página que você pode estar lendo. Para evitar isso, adicione o seguinte código ao seu arquivo user.js:

// Evita reutilizar a janela ativa:
user_pref("advanced.system.supportDDEExec", false);

E porque não usar novas abas em vez de janelas? Se você preferir abas em vez de janelas, é necessário instalar a extensão Tabbrowser, uma extensão muito poderosa que aumenta a funcionalidade da navegação por abas. Depois de instalar a extensão, siga estas instruções:

  1. Certifique-se que não esqueceu de adicionar o código acima ao seu arquivouser.js.
  2. Selecione Ferramentas > Extensões, selecione Tabbrowser Extensions e clique no pequeno ícone Opções icon.
  3. Expanda a lista Category e selecione o primeiro sub-item (supõe-se ler Advanced Tabbed Browsing mas a lista Category é muito estreita).
  4. Na lista de opções suspensa Window Mode, selecione Use multiple browsers only when I open them.

Pronto! Agora qualquer link aberto por um programa externo, como seu cliente de e-mail, abrirá uma nova aba.

Sempre exibir o ícone `Alternar Folhas de Estilo'

O ícone Alternar Folhas de Estilo na barra de status normalmente não é exibido quando há apenas uma folha de estilo disponível em um web site. Para tornar o ícone visível o tempo todo, inclua o seguinte código em seu arquivo userChrome.css:

/* Sempre mostrar o ícone Alternar Folhas de Estilo na
Barra de Status {
   display: -moz-box !important;
   list-style-image: url(chrome://browser/skin/page-themes.png);
   padding: 0px 3px;
}
Desativar target="_blank"

O Firefox tem um bloqueador de pop-up embutido que está ativado por padrão. Porém ele não impede a abertura de páginas em novas janelas pelo uso das propriedades ilegais target="_blank" ou target="_new". Para forçar a abertura destes links na mesma janela, inclua o seguinte código ao seu arquivo user.js file:

// desativar target="_blank" (abre na mesma janela):
user_pref("browser.block.target_new_window", true);
Usar páginas de erro em vez de caixas de diálogo

Por padrão, o Firefox exibe mensagens de erro irritantes se a conexão falhar, em vez de exibir informações de erro silenciosamente na janela do navegador como o Internet Explorer faz. Para desativar as mensagens de erro e em vez disso usar páginas, adicione o seguinte código ao seu arquivo user.js:

// Em vez de caixas de diálogo de erro irritantes,
exibe páginas:
user_pref("browser.xul.error_pages.enabled", true);

Note que este recurso ainda tem alguns bugs como, por exemplo, remover a última página visitadas do botão de histórico Voltar.

Localizar ao Digitar

Localizar ao Digitar, um novo e interessante recurso introduzido no Mozilla, tem algumas configurações ocultas que podem ser alteradas para melhor atender às suas necessidades. Adicione o seguinte código ao seu arquivo user.js:

// Configuração para Localizar ao Digitar:
// Defina esta preferência como false para desativar a opção de Localizar ao Digitar:
user_pref("accessibility.typeaheadfind", true);
// Defina esta preferência como true, você pode
iniciar automaticamente o Localizar ao Digitar.
// Defina esta preferência como false (padrão), você tem que pressionar / (localizar texto) ou ' (localizar links) antes de sua busca.
user_pref("accessibility.typeaheadfind.autostart", true);
// Defina esta preferência  como false if you want Find As You Type to search normal text too:
user_pref("accessibility.typeaheadfind.linksonly", true);
// Defina esta preferência como false se você també
quer Localizar texto digitar:
user_pref("accessibility.typeaheadfind.startlinksonly", false);
// Este é o tempo, em milisegundos, para que o Pesquisar ao Digitar pare
de aguardar o pressionamento de teclas:
user_pref("accessibility.typeaheadfind.timeout", 3000);

Para mais informações sobre o que é Localizar ao Digitar, leia esta documentation.

Desativar outros recursos de JavaScript para janelas

O Firefox tem algumas opções que permitem-lhe decidir o que os scripts podem ou não fazer com as janelas. Estas opções estão disponíveis no menu Ferramentas > Opções > Facilidades > Advançado. Porém, esta lista de opções não cobre tudo. Há algumas outras opções úteis que podem ser aplicadas adicionando o seguinte código ao seu arquivo user.js:

// Mais opções de DOM/JavaScript
// Garantir que todas as janelas popup sejam redimensionáveis:
user_pref("dom.disable_window_open_feature.resizable", true);
// Garantir que todas as janelas popup sejam minimizáveis:
user_pref("dom.disable_window_open_feature.minimizable", true);
// Sempre exibir o menu em janelas popup:
user_pref("dom.disable_window_open_feature.menubar", true);
// Sempre exibir a barra de Navegação em janelas popup:
user_pref("dom.disable_window_open_feature.location", true);
// Sempre exibir a barra de rolagem em janelas popup:
user_pref("dom.disable_window_open_feature.scrollbars", true);
Use seus Favoritos do Netscape 6/7 ou Mozilla no Firefox

Se você usa Netscape 6/7 ou o Mozilla você pode compartilhar seus Favoritos com o Firefox. Todos os Favoritos são armazenados em um arquivo chamado bookmarks.html e são guardados em uma pasta de perfil. Por exemplo, se você quer usar os Favoritos do Netscape 7 no Mozilla Firefox, adicione o seguinte código ao seu arquivo user.js:

// Especifique qual arquivo de favoritos usar:
user_pref("browser.bookmarks.file", "C:\Caminho_Para_Seu_Perfil_do_Netscape\bookmarks.html");

Lembre-se de usar duas barras invertidas para separadores de caminho se você usa Windows, por exemplo, "C:\Caminho\bookmarks.html" em vez de C:\Caminho\bookmarks.html.

Esta dica também aplica-se a sistemas de dupla ou múltipla inicialização (dual-boot) para usar os mesmos favoritos em ambos os sistemas. Apenas certifique-se de colocar o arquivo em um local em que você tem permissão de escrita.

Por padrão, se você digitar um termo no campo endereço e pressionar a tecla Enter, será executada um busca "Estou com sorte" ("I'm Feeling Lucky") no Google, que levará diretamente ao primeiro resultado. Se preferir usar um padrão de busca em forma de lista, inclua o seguinte código em seu arquivo user.js:

// Altera a busca normal do Google:
user_pref("keyword.URL", "http://www.google.com/search?btnG=Google+Search&q=");

É claro, você também pode alternar para um sistema de busca completamente diferente alterando a expressão de busca para algo semelhante. A expressão de busca padrão é: "http://www.google.com/search?btnI=I%27m+Feeling+Lucky&q=".

Desativar ícones de Favoritos

Você pode desativar a exibição de ícones de bookmark e "favicons" adicionando o seguinte código ao seu arquivo user.js:

// Desativar ícones de Favoritos
user_pref("browser.chrome.site_icons", false);
user_pref("browser.chrome.favicons", false);
Mudar a URL do indicador de atividade (throbber)

Ao clicar no Indicador de Atividade (também conhecido como "throbber"), você é direcionado para o endereço dele. Isto pode ser alterado para abrir qualquer URL adicionando o seguinte código ao seu arquivo user.js:

// Clique no throbber para ir para o Mozilla.org:
user_pref("browser.throbber.url", "http://www.mozilla.org/");
Evitar que as URLs sejam salvas na Barra de Endereços

O Firefox pode evitar que as URLs sejam salvas no menu deslizante da Barra de Endereços. Esta restrição ajuda a proteger a privacidade do usuário e previne que os usuários "tropecem" em sites que outros usuários visitaram anteriormente.

Andrew Mutch escreveu uma página explicando como implementar esta restrição. Leia aqui.

Evitar que um site desative o menu de contexto

Alguns sites evitam que você clique com o botão direito sobre a página para exibir o menu de contexto. Este favorito desativará estas tentativas com apenas um clique. Arraste o link abaixo para sua pasta de favoritos do Firefox ou para seu menu Favoritos, para criar um marcador:

Ativar menu de contexto

Alternativamente, clique com o botão direito sobre o link e selecione Adicionar link aos favoritos....

Aparência das páginas web

Bloqueio de Propagandas

Propagandas em web sites são irritantes, freqüentemente interrompendo o texto e fazendo a janela piscar para ganhar sua atenção. Há um truque engenhoso que você pode usar para bloquear a maioria das propagandas em páginas Web.

Devido ao tamanho do código desta dica, isto está disponível em uma página separada.

É provável que você simplesmente ache cansativo o texto piscante logo acima. Para evitar isso, adicione o seguinte código ao seu arquivo user.js:

// Ponha um fim nos textos piscantes!
user_pref("browser.blink_allowed", false);
Desativar tags <marquee>

Alguns sites usam tags marquee para texto deslizante. Se você não acha isso útil, adicione o seguinte código ao seu arquivo userContent.css:

/* Basta nestas tags <marquee>! */
marquee {
   -moz-binding                  : none !important;
   display                       : block;
   height                        : auto !important;
}

Se você incluiu o código, este texto não deveria rolar depois de reiniciar o Firefox.

Forçar frames redimensionáveis

Muitos sites usam frames para exibir seus conteúdos e algumas vezes estes são muito pequenos. Para fazer com que todos os frames sejam redimensionáveis, adicione o seguinte código ao seu arquivo user.js:

// Forçar frames redimentsionáveis
   user_pref("layout.frames.force_resizability", true);

Note que isto também fará os frames aparecerem com uma borda de largura fixa e então pode fazer as páginas parecerem bizarras.

Mudar o cursor dos links que abrem em novas janelas

Esta dica engenhosa muda o ponteiro do mouse quando você move-o sobre links que abrirão em uma nova janela. Adicione o seguinte código ao seu arquivo userContent.css file:

/* Mudar o cursor para links que abrem em nova janela */
:link[target="_blank"], :visited[target="_blank"],
:link[target="_new"],   :visited[target="_new"] {
   cursor:  crosshair;
} 
Mudar o cursor para links JavaScript

Esta dica alterará o ponteiro do mouse quando você movê-lo sobre links que executarão um comando JavaScript. Adicione o seguinte código ao seu arquivo userContent.css:

/* Mudar o cursor para links JavaScript */
a[href^="javascript:"] {
   cursor: move;
} 

Outras dicas

Alterar o idioma em páginas web

Alguns websites oferecem conteúdo em múltiplos idiomas. Você pode escolher muitos idiomas no Firefox e elas serão tratadas em ordem de prioridade. Para alterar a prioridade, simplesmente vá até Editar > Preferências..., selecione a seção Geral e clique no botão Idiomas.

Executar o Firefox a partir de uma mídia removível

Esta dica avançada torna possível executar o Firefox a partir de dispositivos removíveis, como pentes de memória USB. Isto permitirá executar o Firefox com suas próprias configurações pessoais a partir de qualquer computador, mesmo que você não tenha o Firefox instalado. Isso foi testado apenas em Windows XP/2000. As instruçõs;es básicas s&atide;o as que se seguem:

  1. Copie a pasta do aplicativo Firefox a pasta do seu perfil pessoal para uma mídia removível. Neste exemplo utilizaremos R:\Firefox para a pasta do aplicativo e R:\FFProfile como a pasta do perfil, assumindo que a letra do drive para a mídia removível seja R:.
  2. Crie um arquivo em lote (batch) chamado R:\Firefox.bat, com a seguinte linha:
    start \Firefoxirefox.exe -profile \FFProfile
    
  3. Opcionalmente, desative o cache em disco para reduzir a número de vezes que se grava arquivo em mídia removível entrando em about:config na barra de Endereços do Firefox e defina a variável browser.cache.disk.enable para false.

A necessidade de um arquivo batch é em vez de um simples atalho é que um atalho usa caminhos absolutos e como a letra atual para a mídia removível pode mudar, dependendo de qual computador você está conectado, o caminho relativo usado no arquivo batch é garantido que funciona em qualquer lugar.

Selecionar e copiar células individuais em tabelas

Ao pressionar a tecla Ctrlvocê pode selecionar células de tabelas. Apenas clique em qualquer região sem links da célula. Você pode selecionar múltiplas células, clicando individualmente nas células que você quer selecionar ou apenas arrastando com o mouse. Depois de selecionado, você pode usar Copiar e Colar do mesmo modo que faria em uma seleção de texto.

Agilizar o redesenho de páginas

Por padrão o Firefox não tenta redesenhar uma página web por 250 milisegundos porque ele está esperando dados. Se você adicionar o código abaixo ao seu arquivo user.jso Firefox imediatamente tentará redesenhar a página, mesmo sem os dados completos. O inconveniente ocorre em máquinas mais lentas onde um "refluxo" pode realmente fazer o tempo de carga da página aumentar.

// Isto faz uma grande diferença. O último valor é em milisegundos (o padrão é 250)
user_pref("nglayout.initialpaint.delay", 0);
Ativar Pipelining

Pipelining ainda é um recurso experimental, desenvolvido para melhorar a performance de carga da página, porém isso não é bem suportado por alguns servidores web e proxies. Para experimenta-lo, adicione o seguinte código ao seu arquivo user.js:

// Ativar pipelining:
user_pref("network.http.pipelining", true);
user_pref("network.http.proxy.pipelining", true);
user_pref("network.http.pipelining.maxrequests", 100);
Especificar onde armazenar o cache

Para especificar em quais pastas o cache será armazenado, adicione o seguinte código ao seu arquivo user.js:

// Caminho para a pasta Cache:
user_pref("browser.cache.disk.parent_directory","C:\Caminho\Caminho para o Cache");

Lembre-se de usar duas barras invertidas para os separadores de caminho se você usa Windows, por exemplo, C:\Caminho\Caminho para o Cache instead of C:\Caminho\Caminho para o Cache.

Definir o uso de memória cache

Normalmente o Firefox determina o uso de memória cache dinamicamente baseado na quantidade de memória disponível. Para especificar a quantidade de memória cache, adicione o seguinte código ao seu arquivo user.js:

// Especificar a quantidade de memória cache:
// -1 = determina dinamicamente (padrão), 0 = nenhuma, n = capacidade da memória, kilobytes
user_pref("browser.cache.memory.capacity", 4096);

Para desativar completamente o uso de memória cache, adicione o seguinte código:

// Desativa a memória cache:
user_pref("browser.cache.memory.enable", false);
Navegador-Quiosque

Andrew Mutch escreveu um extenso tutorial que explica como modificar o Firefox para rodar em modo de estilo quiosque. Leia tudo sobre isto aqui.

Muitas bibliotecas estão disponibilizando catálogos online baseados na web e acesso à bancos de dados online. Frequentemente estas bibliotecas não querem que os computadores fornecidos para isso tenham acesso à toda Internet. Este método lhe ajudará a limitar o Firefox para que acesse um número predefinido de sites.

Restringir acesso à web pode ser feito com o uso de configurações de proxy no Firefox. Leia tudo sobre como fazer isso nesta página, escrita por Andrew Mutch.

Devido ao uso de <marquee>, esta página não é validada como HTML 4.01 Strict.

© 2002-2004 David Tenser.


firefox firefox community website